The catalog requires a modern web browser - like Google Chrome, Firefox, or Internet Explorer 8 or newer with Javascript turned on.